$re = '/Сверхъестественное.*\[1080p\]/';
$str = '
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few). (S11E22)
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [1080p].(S11E22)
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [1080p]l
Сверхъестественное (Supernatural). Горсточка счастливцев (We Happy Few) [MP4]. (S11E22))
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);