using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\S+=registration\.activate\&.*";
string input = @"https://niveauescort.com/index.php/register?task=registration.activate&token=19a1a2bfa71ffd38a49cef3e72309f7b";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}