package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^\S+=registration\.activate\&.*`)
var str = `https://niveauescort.com/index.php/register?task=registration.activate&token=19a1a2bfa71ffd38a49cef3e72309f7b`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}