$re = '/^\S+=registration\.activate\&.*/i';
$str = 'https://niveauescort.com/index.php/register?task=registration.activate&token=19a1a2bfa71ffd38a49cef3e72309f7b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);