// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^\S+=registration\.activate\&.*").unwrap();
let string = "https://niveauescort.com/index.php/register?task=registration.activate&token=19a1a2bfa71ffd38a49cef3e72309f7b";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}