$re = '/^\>(.*?)(?=\>|\n\n)/ms';
$str = '> this is a match
> so is this, but should be in the same match as above
> this should be a seperate match > this is nothing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);