use strict;
my $str = 'https://t.me/+-k0L3asdxMc2Mjc8
https://t.me/telegram
telegram.t.me
telegram.telegram.me
t.me/telegram
https://www.t.me/+-k0L3asdxMc2Mjc8
telegram.t.me
tel_egram.t.me
';
my $regex = qr~^(https?://)?((www\.)?t(elegram)?\.(dog|me)/((?![_\d])(?!.*__)(?!.*_$)\w{4,}[a-z\d]|[\w\+-]{13,17})|(?![_\d])(?!.*__)(?!.*_$)\w{4,}[a-z\d]\.(t(elegram)?\.(dog|me)))~imup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}