# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(https?://)?((www\.)?t(elegram)?\.(dog|me)/((?![_\d])(?!.*__)(?!.*_$)\w{4,}[a-z\d]|[\w\+-]{13,17})|(?![_\d])(?!.*__)(?!.*_$)\w{4,}[a-z\d]\.(t(elegram)?\.(dog|me)))"
test_str = ("https://t.me/+-k0L3asdxMc2Mjc8\n"
"https://t.me/telegram\n"
"telegram.t.me\n"
"telegram.telegram.me\n"
"t.me/telegram\n"
"https://www.t.me/+-k0L3asdxMc2Mjc8\n"
"telegram.t.me\n"
"tel_egram.t.me\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.