#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![A-Za-z]\d?$)[a-zA-Z]+\d*$"
Local $sString = "tt" & @CRLF & _
"tt2" & @CRLF & _
"test" & @CRLF & _
"a11" & @CRLF & _
"" & @CRLF & _
"t2" & @CRLF & _
"t" & @CRLF & _
"1" & @CRLF & _
"t1t"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")