import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![0-9-]+$)(?:[a-z]{2,}-?|[0-9]-?)+(?<!-)$";
final String string = "\n"
+ "(NULL STRING ABOVE)\n"
+ "555\n"
+ " 5\n"
+ " 5-yes\n"
+ " this-slug\n"
+ "--bad-slug\n"
+ "-bad-slug\n"
+ "bad--slug\n"
+ "bad-slug-\n"
+ "bad-slug--\n"
+ "b\n"
+ "a\n"
+ "d\n"
+ "b-a-d\n"
+ "go-od-2-ba-d\n"
+ "1-b\n"
+ "good-b4d\n"
+ "1-1b\n"
+ "1-1\n"
+ "1-2-33\n"
+ "go-od-to-go\n"
+ "1-good-slug\n"
+ "10-good-slugs\n"
+ "best-slug-ever\n"
+ "good-slug\n"
+ "slug-123\n"
+ "good\n"
+ "good-1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}