use strict;
my $str = 'DOT_ENV=dotenv
#DOTENV=dotenv
DOT_ENV= asdf asf
DOTENV=\'dot env\'
DOTENV="dot env"
DOT_ENV=\'dotenv\'
DOT_ENV="DotEnv"
DOTENV="Dot\\nEnv"
DOTENV="{"Dot":"Env"}"
export DOTENV="dotenv"
DOTENV ="dot env"
DOTENV= "dot env"
DOTENV = "dot env"';
my $regex = qr/^(?:export\s+|)(?<key>[[:alnum:]_]+)=((?<quote>["'])?(?<val>.*?[^\\])\k<quote>?|)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}