package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`s`)
var str = `need to implement method call
line.append(string)
something.something(optional)
function call
print()
print("hello")
func (weird, func, call)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}