import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "s";
final String string = "need to implement method call\n"
+ "line.append(string)\n"
+ "something.something(optional)\n"
+ "function call\n"
+ "print()\n"
+ "print(\"hello\")\n"
+ "func (weird, func, call)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}