import re
regex = re.compile(r"(\+43 \d{2})(\d) ", flags=re.MULTILINE)
test_str = ("+43 123 45 67\n"
"+43 234 56 78\n")
subst = "$1 $2"
result = regex.sub(subst, test_str)
if result:
print(result)