re = /(?:w+])*(?:[x84])(?<li>[\s\S]*?[;.])/m
str = 'Faire cheminer les modifications règlementaires selon les différentes instances (processus de gouvernance) :
Approbation du principe de révision réglementaire par le comité de direction;
Approbation des orientations par le CA;
Consultation de la nouvelle règlementation auprès du CFPIC (avis);
Approbation et adoption de la nouvelle règlementation par le CA;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end