re = /(subject name=\"(?:Biology|chem102)\"[\s\S]+?)\r?\n^topic$|(^topic$\r?\n)/m
str = 'subject name="Biology" value="12th"
topic name="system" value="anything"
topic
subject name="mathematics" value="12th"
topic name="system" value="anything"
other topics ="anything" value="anything"
topic
subject name="chem102" value="12th"
topic name="system" value="anything"
topic
subject name="ComputerSc" value="12th"
topic name="system" value="anything"
other topics ="anything" value="anything"
topic'
subst = '\\1\\2\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result