import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?=[A-Z]+=\\d+,[A-Z]+=\\d+,[A-Z]+=\\d+\\})(?=[^\\}]*\\bAU=17\\b)(?=[^\\}]*\\bBVW=2\\b)(?=[^\\}]*\\bCXYZ=321\\b)";
final String string = "{AU=17,BVW=2,CXYZ=321}\n"
+ "{BVW=2,CXYZ=321,AU=17}\n"
+ "{CXYZ=321,AU=17,BVW=2}\n"
+ "{AU=170,BVW=2,CXYZ=321}\n"
+ "{AU=17,BVW=2,CXYZT=321}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}