using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?<END>\n\n|$)
(?<LINE>\n.++)
)
(?!.{7}).(*SKIP).(?=(?:....(?&LINE){3,}|..|.(?&LINE)|(?&LINE){2})(?&LINE)(?&END))
|(?<=\n)(*SKIP)..(?=.++(?&LINE){3}(?&END))
|(?<=\n.)(*SKIP)..(?=.++(?&LINE){2}(?&END))
|(?<=\n..)(*SKIP)..(?=.++(?&LINE)(?&END))
|(?<=\n...)(*SKIP)(?=.++(?&END)).+(?=...(?&END))
|(?:(?<=\n....)|(?<=^....))..(*SKIP)(?=.++(?&LINE){4})";
string input = @"aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}