package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}(:\d{2}){2}$`)
var str = `
22:33:44
02:33:44
But not as
22:33:44 d
d 22:33:44
f 02:33:44 f`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}