import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{2}(:\\d{2}){2}$";
final String string = "\n"
+ "22:33:44\n"
+ "02:33:44\n\n"
+ "But not as \n\n"
+ "22:33:44 d\n"
+ "d 22:33:44\n"
+ "f 02:33:44 f";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}