re = /[^\s,][^,]*(?=(?:,[^,]*){0,2}$)/m
str = 'V1, V2, V3, V4, V5, V6, V7, V8, V9, V10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end