package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\.\[[^][]*\])\s*`)
var str = `It reported the proportion of the edits made from America was 51% for the Wikipedia, and 25% for the simple Wikipedia.[142] The Wikimedia Foundation hopes to increase the number in the Global South to 37% by 2015.[143]`
var substitution = "\1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}