#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{8}[A-Z]|\d{1,8})$"
Local $sString = "# Correctos (incluyendo parciales)" & @CRLF & _
"1" & @CRLF & _
"12" & @CRLF & _
"123" & @CRLF & _
"1234" & @CRLF & _
"12345" & @CRLF & _
"123456" & @CRLF & _
"1234567" & @CRLF & _
"12345678" & @CRLF & _
"12345678Z" & @CRLF & _
"" & @CRLF & _
"# Incorrectos" & @CRLF & _
"1Z" & @CRLF & _
"123456789" & @CRLF & _
"1/" & @CRLF & _
"/" & @CRLF & _
"@#~" & @CRLF & _
"12345678AZ" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")