$re = '/n">\K(.*?)(?=<)/';
$str = '<div class="schema-product__part schema-product__part_4">
<div class="schema-product__title">
<a data-bind="attr: {href: product.html_url}" href="https://catalog.onliner.by/mobile/xiaomi/redmi416gr">
<span data-bind="html: product.extended_name || product.full_name">Xiaomi Redmi 4 16GB Gray</span>
</a>
</div>
<!-- ko if: !$root.isSimplifiedView -->
<div class="schema-product__description">
<span data-bind="html: product.description">Android, экран 5" IPS (720x1280), ОЗУ 2 ГБ, флэш-память 16 ГБ, карты памяти, аккумулятор 4100 мАч, 2 SIM, цвет темно-серый</span>
</div>
<div class="schema-product__info">
<div class="schema-product__rating-group">
<!-- ko if: product.reviews && product.reviews.count -->
<a class="schema-product__rating" data-bind="attr: {href: product.reviews.html_url}" href="https://catalog.onliner.by/mobile/xiaomi/redmi416gr/reviews">
<span data-bind="attr: {class: \'rating rating_\' + product.reviews.rating}" class="rating rating_45"></span>
<span class="schema-product__review-count">
<span data-bind="text: product.reviews.count">28</span>
<span data-bind="text: $root.format.pluralForm(product.reviews.count, [\'îòçûâ\', \'îòçûâà\', \'îòçûâîâ\'])">îòçûâîâ</span>
</span>
</a>
<!-- /ko -->
<!-- ko ifnot: product.reviews && product.reviews.count --><!-- /ko -->
</div>
<div class="schema-product__info-additional">
<!-- ko if: product.forum.topic_id -->
<a class="schema-product__info-link" data-bind="attr: {href: product.forum.topic_url}" href="http://forum.onliner.by/viewtopic.php?t=18880155">Îáñóæäåíèå</a>
<!-- /ko -->
<!-- ko if: !product.forum.topic_id --><!-- /ko -->
<!-- ko if: product.forum.replies_count -->
<span class="schema-product__topic-count" data-bind="text: product.forum.replies_count">1566</span>
<!-- /ko -->
<!-- ko if: product.review_url --><!-- /ko -->
</div>
</div>
<!-- /ko -->
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);