use strict;
my $str = 'www.google.com
[Tagged](www.google.com)
[Tagged]( www.google.com)
[Tagged ](www.google.com)
,googe.com
.google.com
google.com.
f1.f.com
for.real.com
(?<!\\]\\(\\s*)(?<=\\s|\\(|\\[|^)(?:https?:\\/\\/)?[a-zA-Z0-9]+[a-zA-Z0-9\\-_.]*\\.[a-z]{2,6}[^\\s]*\\b
(google.com)
[google.com]
[ex. http://google.com]
for@real.com
in google.com between
longer form https://google.us.edi?34535/534534?dfg=g&fg in between
';
my $regex = qr/(?<!\]\(\s)(?<=\s|\(|\[|^)(?:https?:\/\/)?[a-zA-Z0-9]+[a-zA-Z0-9\-_.]*\.[a-z]{2,6}[^\s]*\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}