// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https?:\/\/)?(www\.youtube\.com\/watch\?v=)([a-zA-Z0-9_-]+)(&t=)?([0-9]+)?(s)?").unwrap();
let string = "https://www.youtube.com/watch?v=e8WuGzXyO7Y&t=132s";
let substitution = "https://www.youtube.com/embed/$3?fs=1&start=$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}