#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\<[A-Za-z]{5,}\>"
Local $sString = "RegExr was created by gskinner.com, and is proudly hosted by Media Temple." & @CRLF & _
"" & @CRLF & _
"Edit the Expression & Text to see matches. Roll over matches or the expression for details. PCRE & JavaScript flavors of RegEx are supported. Validate your expression with Tests mode." & @CRLF & _
"" & @CRLF & _
"The side bar includes a Cheatsheet, full Reference, and Help. You can also Save & Share with the Community, and view patterns you create or favorite in My Patterns." & @CRLF & _
"" & @CRLF & _
"Explore results with the Tools below. Replace & List output custom results. Details lists capture groups. Explain describes your expression in plain English." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")