package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`I have some text here[\s\S\w\W\d\D]+>(\d{1,2})<`)
var str = `818y1873+130I have some text here09 124i10029102lsdgn2in3>31<
mkm1ikm12klni12m4j12??=?!=I"=and then some text heremsiJR310>39<0MK)==!)="!`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}