package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0?[0-9]{0,4}(?:\.\d+)?|1\d{4}(?:\.\d+)?|20[0-4][0-7][0-8](?:\.\d+)?|20479(?:\.[0-7])?)$`)
var str = `12
20
50
50.45
9999
10000
10000.12
16000
19000
19999
20000.54
20479
20479.00
20479.1
20479.7
Non matching:
20479.8
20480
21000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}