import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0?[0-9]{0,4}(?:\\.\\d+)?|1\\d{4}(?:\\.\\d+)?|20[0-4][0-7][0-8](?:\\.\\d+)?|20479(?:\\.[0-7])?)$";
final String string = "12\n"
+ "20\n"
+ "50\n"
+ "50.45\n"
+ "9999\n"
+ "10000\n"
+ "10000.12\n"
+ "16000\n"
+ "19000\n"
+ "19999\n"
+ "20000.54\n"
+ "20479\n"
+ "20479.00\n"
+ "20479.1\n"
+ "20479.7\n\n"
+ "Non matching:\n"
+ "20479.8\n"
+ "20480\n"
+ "21000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}