re = /"(url|title|tags)":("([^""]+)"|\[[^[]+])/m
str = '"url":"http://www.netcharles.com/orwell/essays.htm",
"domain":"netcharles.com",
"title":"Orwell Essays & Journalism Section - Charles\' George Orwell Links",
"tags":["orwell","writing","literature","journalism","essays","politics","essay","reference","language","toread"],
"index":2931,
"time_created":1345419323,
"num_saves":24'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end