#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{4}|\d{6})$"
Local $sString = "1" & @CRLF & _
"12" & @CRLF & _
"123" & @CRLF & _
"12345" & @CRLF & _
"1234567" & @CRLF & _
"-1234" & @CRLF & _
"1.234" & @CRLF & _
"-1.234" & @CRLF & _
"00000000" & @CRLF & _
"1234" & @CRLF & _
"0000" & @CRLF & _
"1111" & @CRLF & _
"123456" & @CRLF & _
"098765" & @CRLF & _
"000000" & @CRLF & _
"123456" & @CRLF & _
"090909" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")