$re = '/^(?:\d{4}|\d{6})$/m';
$str = '1
12
123
12345
1234567
-1234
1.234
-1.234
00000000
1234
0000
1111
123456
098765
000000
123456
090909
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);