// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d{4}|\d{6})$").unwrap();
let string = "1
12
123
12345
1234567
-1234
1.234
-1.234
00000000
1234
0000
1111
123456
098765
000000
123456
090909
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}