#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+)(.*)\1$"
Local $sString = "abXYab" & @CRLF & _
"xx" & @CRLF & _
"xxx" & @CRLF & _
"xxxx" & @CRLF & _
"javaXYZjava" & @CRLF & _
"javajava" & @CRLF & _
"Hello! and Hello!" & @CRLF & _
"x" & @CRLF & _
"" & @CRLF & _
"abcd" & @CRLF & _
"mymmy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")