$re = '/^(.+)(.*)\1$/m';
$str = 'abXYab
xx
xxx
xxxx
javaXYZjava
javajava
Hello! and Hello!
x
abcd
mymmy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);