import re
regex = re.compile(r"^(.+)(.*)\1$", flags=re.MULTILINE)
test_str = ("abXYab\n"
"xx\n"
"xxx\n"
"xxxx\n"
"javaXYZjava\n"
"javajava\n"
"Hello! and Hello!\n"
"x\n\n"
"abcd\n"
"mymmy")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")