re = /\xFF/m
str = 'HolaÿMundo
Texto sin el carácter especial.
Aquí hay un Alt+255: ÿ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end