# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+\s+\d+,\d+\s+\d+,\d+\s+)\((\s+\d+\s+)\)(\s+)\((\s+\d+,\d+\s)\)(\s+\d+)/$1$2$3$4$5/gm;t' <<< "IBNR 13,123 1,234 ( 556 ) ( 2,355 ) 934 "