use strict;
my $str = 'IBNR 13,123 1,234 ( 556 ) ( 2,355 ) 934 ';
my $regex = qr/(\w+\s+\d+,\d+\s+\d+,\d+\s+)\((\s+\d+\s+)\)(\s+)\((\s+\d+,\d+\s)\)(\s+\d+)/mp;
my $subst = '$1$2$3$4$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";