package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[Z][0-9]`)
var str = `Z001
Z065
Z965
ZB01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}