#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(https?:\/\/\S+)$"
Local $sString = "<div class="text">" & @CRLF & _
"http://2gis.ru" & @CRLF & _
"http://www.yp.ru" & @CRLF & _
"http://www.yell.ru" & @CRLF & _
"http://www.ypag.ru" & @CRLF & _
"http://www.e-adres.ru" & @CRLF & _
"http://infolo.ru" & @CRLF & _
"http://globalmcom.com" & @CRLF & _
"</div>"
Local $sSubst = "$1<br>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)