using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/\S+)$";
string substitution = @"$1<br>";
string input = @"<div class=""text"">
http://2gis.ru
http://www.yp.ru
http://www.yell.ru
http://www.ypag.ru
http://www.e-adres.ru
http://infolo.ru
http://globalmcom.com
</div>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}