import Foundation
let pattern = #"(https?:\/\/\S+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="text">
http://2gis.ru
http://www.yp.ru
http://www.yell.ru
http://www.ypag.ru
http://www.e-adres.ru
http://infolo.ru
http://globalmcom.com
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<br>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)