#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?://\S+?cnbc\.com\S+"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"I have a text file of links after scrapping, I need to make a regular expression for these links so i can extract them from a file, but different links have same structure but different in length, like" & @CRLF & _
"" & @CRLF & _
"https://www.cnbc.com/2016/10/12/billionaire-richard-branson-learned-a-key-business-lesson-playing-tennis.html" & @CRLF & _
"" & @CRLF & _
"and this:" & @CRLF & _
"" & @CRLF & _
"https://www.cnbc.com/2016/10/12/hedge-fund-bonus-makeover.html" & @CRLF & _
"" & @CRLF & _
"I can successfully make RE for the base domain, but after that title give me a tough time, mine is" & @CRLF & _
"" & @CRLF & _
"[h][t][t][p][s]:\/\/[w][w][w].[c][n][b][c].[c][o][m]\/[2][0][1][5-8] " & @CRLF & _
"" & @CRLF & _
"for https://www.cnbc.com/2016/10/11/ but dont know how to make for further with diiferent words for different links ahead," & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")