import Foundation
let pattern = #"([a-z]+[A-Z]+\w*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(e.g. wOrd instead of word; leSS instead of less).
UPperCaSe
USA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\L\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)