package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\/]+\/(?:test|foo|bar)\/(?:baz|en|ppp)\/[\w-]+\/.*$`)
var str = `www.mysite.com/bar/baz/myParam/...anything here
www.mysite.com/bar/baz/?uid=100/..
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}