re = /^[^\/]+\/(?:test|foo|bar)\/(?:baz|en|ppp)\/[\w-]+\/.*$/m
str = 'www.mysite.com/bar/baz/myParam/...anything here
www.mysite.com/bar/baz/?uid=100/..
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end