#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*key1=[a-z0-9,]*d[1-4])(?=.*(?:key1=[a-z0-9,]*a[12]|key2=[a-z0-9,]*b[123]|key3=[a-z0-9,]*c[123])).+"
Local $sString = "key1=a2,d3" & @CRLF & _
"key2=b1,b3key1=d1" & @CRLF & _
"key2=b2key3=c3,a2key1=d4" & @CRLF & _
"key1=d2abckey2=b2,b3key1=a1" & @CRLF & _
"" & @CRLF & _
"key1=d2" & @CRLF & _
"key1=a1key2=b1" & @CRLF & _
"key2=b2key3=a1" & @CRLF & _
"key1=a2,d3" & @CRLF & _
"key1=d3,a2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")