using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n(?![^<]*<\/pre>)";
string substitution = @"";
string input = @"<p>Test contennt for regex
with line breaks</p>
<pre>code block
with multi line content
working fine</pre>
<pre class=""brush:C#"">
test line break before
open paranthesis < is not working fine
line breaks after paranthesis
is accepted
</pre>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}